Ubuntu でサスペンドやハイバネートが出来ない問題

僕の使っているノートPCにはUbuntu 11.04が入っているのですが,サスペンドとハイバネートができなくて,かなり不便に感じていました.

サスペンドやハイバネートが出来ないという状態は,サスペンドやハイバネートに移行する途中で完全にフリーズしてしまうという状態です.
この問題はUbuntu 10.04の時ぐらいから引きずっていて,調べても中々解決策が見つからずに今日まで過ごしてきたわけですw

しかし,ようやくこの問題の解決策を見つけたので,紹介します.

見つけたのはこのページです.

Fix Ubuntu (or Linux) Suspend/Hibernate Not Working Bug

ここにあるスクリプトを書いたら解決しました!
(上のページのコメント欄でも結構苦しんでいた人がいますねw)
上のページのままですが,ここにも書いておきたいと思います.
sudo gedit /etc/pm/sleep.d/10_custom-ehci_hcd
でファイルを作成します.
このファイルに次のスクリプトを書いて保存します.
#!/bin/sh
#inspired by http://art.ubuntuforums.org/showpost.php?p=9744970&postcount=19
#...and http://thecodecentral.com/2011/01/18/fix-ubuntu-10-10-suspendhibernate-not-working-bug    
# tidied by tqzzaa :)

VERSION=1.1
DEV_LIST=/tmp/usb-dev-list
DRIVERS_DIR=/sys/bus/pci/drivers
DRIVERS="ehci xhci" # ehci_hcd, xhci_hcd
HEX="[[:xdigit:]]"
MAX_BIND_ATTEMPTS=2
BIND_WAIT=0.1

unbindDev() {
  echo -n > $DEV_LIST 2>/dev/null
  for driver in $DRIVERS; do
    DDIR=$DRIVERS_DIR/${driver}_hcd
    for dev in `ls $DDIR 2>/dev/null | egrep "^$HEX+:$HEX+:$HEX"`; do
      echo -n "$dev" > $DDIR/unbind
      echo "$driver $dev" >> $DEV_LIST
    done
  done
}

bindDev() {
  if [ -s $DEV_LIST ]; then
    while read driver dev; do
      DDIR=$DRIVERS_DIR/${driver}_hcd
      while [ $((MAX_BIND_ATTEMPTS)) -gt 0 ]; do
          echo -n "$dev" > $DDIR/bind
          if [ ! -L "$DDIR/$dev" ]; then
            sleep $BIND_WAIT
          else
            break
          fi
          MAX_BIND_ATTEMPTS=$((MAX_BIND_ATTEMPTS-1))
      done  
    done   fi
  rm $DEV_LIST 2>/dev/null
}

case "$1" in
  hibernate|suspend) unbindDev;;
  resume|thaw)       bindDev;;
esac
これで完了です!
あとはサスペンドやハイバネートを試してみてください.
僕はサスペンドはできるようになりましたが,ハイバネートはダメでした.
ハイバネートが出来ないのは,スワップ領域が足りないから(というエラーが表示されました)で問題としては別になります.
(スワップ領域を広げてやればできるはず)
ちなみに使っているマシンは
ASUS U30Jc-QX019E
です.

Ubuntu 11.04 Rails 導入備忘録 Part.1

Railsの導入備忘録です。

導入環境は,

Ubuntu 11.04 i386

です。

Rails 3も出ていますが,書籍でのバージョンに沿って3以前のバージョンを利用します。

まず,apt-getから「ruby」,「rubygems」他依存関係のインストールをします。

sudo apt-get update<br>sudo apt-get install build-essential libopenssl-ruby<br>sudo apt-get install ruby rubygems ruby1.8-dev libsqlite3-dev<br>

次に,RubyGemsから,Railsとその依存関係のインストールです。
sudo gem update --system<br>sudo gem install rails --version "<2.9.9"<br>sudo gem install sqlite3-ruby<br>

※Railsのバージョンは3以前です。

とりあえず,これでRailsは動きました。